Add value to attribute in existing data model

We have a data model that has been in use for some months. One of our Categories has several Attributes and each Attribute (single select List) has several Values to choose from. An Attribute can’t be selected unless its Value is specified.

The issue we have found is that the Category can be recorded as an observation without any Attribute/Value being selected.

There doesn’t seem to be a way to require “at least one Attribute is selected” for the Category.

My work around idea now is to require that ALL Attributes in the Category must be assigned a Value, and to include the Value “none” in the list of each Attributes. That will force users to go through all Attributes but should reduce chance of a blank record.

The data model has allowed me to add the new Value to the list, and it appears in the Configurable Model, and I’ve ensured the Value is “enabled” in the configurable model. But the Value is still not appearing as an option for the Attribute when deployed in the package.

Is this a feature that you can’t add new levels to an Attribute that already has records in the database?

Do I have to create a whole new Category+Attributes in the Data Model that duplicates the original Category+Attributes, and remove the original one from the configurable model?

If I do that does it mean the resulting data will occupy different fields in the database to original version of that Category?

Many thanks for any help.


Hi Jeremy,

Just checking you’re using the “required” option for these attributes in the data model?

We realise that adding the need for attributes to be mandatory should be available in the configurable model and this is being looked into for development.

No, this should not be the case. You should be able to add list values to existing attributes in your data model and have them display in your configurable models. But, by default the new options can be disabled. Make sure to go into your configurable model (which should automatically have the new list values) select the attribute, select the edit option by configuration, find the values that are not displaying, select them and select “enable”.



Thanks Alex.

I feel I tried all that but couldn’t get it to appear on mobile app


Hey Jeremy,

That should definitely do it. Could you re-try these steps (maybe create a new model) to confirm. If the options still won’t show please share some screenshots and a bug report from the Mobile app (and the error log from the desktop if any errors are popping up) and the team can look into it.



1 Like

Depending on what edits you have made to the configurable model you may need to either edit any customizations of the attribute in the configurable model or revert to the data model version. In some cases, depending on how the configurable model was built, edits to attributes are not automatically added to the configurable model.

1 Like