Can't open images SMART 6.3

Hi Forum,

Attachments were working fine through SMART before an opening without any issues. Now when we try to open attachments it is giving us several errors. I hope you can help us make these attachments work again!

I have attached a screenshot of the error we are getting along with the error .log (it won’t let me upload the error log I’ve just realised so please let me know who to send this to).



Hi Xia,
A couple of thoughts on this:

  1. Are you able to find that .jpeg file in the filepath specified and open it outside of SMART?
  2. What format is your error log file in? You should be able to attach .txt files in posts.

just an FYI, if you use windows/Mac file managers to try and open attachments within the filestore (at least on most recent versions of SMART 6.X+) you can see the files, but they are encrypted, so you won’t be able to open them directly in the file manager. This is a feature so people that are not logged in can’t see potentially private files/images etc.

To debug though, you should be able to see the files there in the file manager at least. If it doesn’t exist at all that is probably a permissions issue when creating/importing the patrol/attachment, or potentially your file space was full and it wasn’t created? Make sure you are logged into Windows as an admin user and restart SMART.

Hey @matt.hron thanks for the advice. Yes the file is a .txt but whenever I try to upload it I get the error : “Sorry new users cannot upload attachments”. ?

Hey @jeffloun thanks for your response! I will have the site look into what you have suggested and let you know. Cheers,


Thanks Xia. There was a setting preventing new users from adding attachments, and I’ve removed that limitation, so you should be able to add the error log now.

Hi All, Kelly here, thank you so much for your help on this…I don’t think it is a permissions issue as when I re-import one of the same patrols the attachments work fine. I am also logged in to windows, so I don’t believe that’s the fault.

Do you think this could be related to the server not completely uploading the attachments? I had issues uploading to the server a few weeks ago, before all that all patrols and attachments worked fine, but did not realize the attachment error until after re-downloading the CA from the server.

But It also could be completely unrelated.

Thanks Kelly

[Angola LLNP - Log Error (1).txt|attachment](upload://@jeffloun TAOfbC0uUtKliKhwUydKkMfk.txt) (442.8 KB)

Hi @jeffloun @matt.hron see the error log attached for Kellys issue.

I am also having the same issue with a different site on 6.3 so I will send that error log and screenshots through in a moment.


@matt.hron , here is the same issue but for Conservation South Luangwa that they’ve just reported today @KalubaT – Any guidance would be much appreciated.

Kindest Regards,
CSL.Log.txt (223.2 KB)

Sorry it is also only letting me upload one photo at a time :frowning:

Is it possible for you to send me the URL, username/password for Connect and username/password for the South Luangwa CA so I can download the CA and login to see it directly? If so, just email it to me directly so we aren’t posting login credentials here, thanks.

Hi Jeff, Thank yu. @KalubaT please confirm you are fine with me sending Jeff some credential so he can investigate?

Hi @jeffloun Kaluba has given me the go ahead, I will send you now privately on SLACK. Cheers,

I was able to take a look at the CSL CA off the Connect server. I don’t really have any incite in what happened to get the CA into the state that I see when I download the CA. It appears to have 0 attachments (Query for all observations and the ‘attachements’ tab is empty), but I can see there are a hundred or so files in the folders where attachments are stored, so the database appears to no longer have any record of what observations those attachments were attached to I guess.

This is not the same error as above, so I think the desktop CA that users has is in a different state, where they database still has links to the attachments setup, but the files are not there. That type of thing is possible if there was a problem transferring the attachment from Mobile to Connect, which I recall was reported a few times before. I think the causes for those instances we fixed between 6.3 and the latest 7.5.3 versions, so that might help once you are able to upgrade.

In terms of the odd CSL CA that has no attachments, I would suggest taking a look at any backup you have and seeing if this is just a recent issue and maybe you could restore a backup to go back to. I’d also suggest reviewing anything that might have caused the issue, all I can think of is users deleting patrol days or otherwise making edits to the patrol times and dates that might orphan the observations those attachments I can see in the files used to be related to.

I’m happy to test other CAs if the “file found error” is happening in other CAs as well, I randomly picked the “Hook Bridge” CA and the attachments in that one are working fine at a glance. Let me know the CA names and specific patrol IDs if they are causing errors and I can take a look.