Maps in SMART Mobile


I have multiple CAs logged on my mobile device, each with their own basemap.

I have realised that whenever I click on the map icon, couple of things are strange:

  1. It shows my location (Cape Town) but there is a straight dashed red line that goes up to Tunisia, as if my map was in Tunisia. The map does not appear whether I zoom in or out.
  2. When I click on layer for any of the CAs, I see ALL my basemaps for ALL my CAs and all the basemaps appear. It means that each CA can see the basemap of other CAs.
  3. Under Offline layer, I see the names of all my CAs + plenty basemaps called “SMART map”. The basemaps “SMART map” all work, meaning I can see my maps but they don’t have specific names so I never know which one is which. When I click on the basemap with a specific name, nothing happen.

As each CA has its own basemap, should I not only see the basemap of that CA and not everyone’s else?
Why only the layers call “SMART map” work and not the one that have names and that are associated with the data model?

I am obviously doing something wrong so looking forward for some help!

Thanks & regards,


Hi Marine,

Thank you for this feedback. Currently, we do not have the ability to rename / label different basemaps in SMART Mobile. This is something that has been raised for development.

That said, you should be able to switch between projects from different CAs and have only the basemap(s) for that CA visible when accessing the map from within the project. I’ve just checked and I seem to be seeing a similar thing in my app. Can I confirm you’re also using SMART Mobile v453?

The straight dashed line usually indicates a recorded observation (perhaps an observation erroneously created due to GPS error?). That said, once data is exported this should no longer appear but I’m guessing this is not disappearing when you have exported your data?

Would it be possible to share a screenshot and a bug report from the device?

Thanks a lot.



Hi Marine,

In addition to what Alex said…

The straight red line is a navigation point. If you click on the button in the bottom right corner on the Map page and select Navigation and then click Stop, it will remove the red line.

When an offline layer is active, then there is a magnifying glass icon next to it. You can select this and it will zoom to the extent of that map.

If your CAs are all for different areas, then you could just enable all the “SMART map” entries and not worry about it from there.

If you are finding that your map is not visible at the resolution you require, then you may want to play with the desktop settings when you generate the map.

If you have relatively static maps for your CAs, then you could create your own map layer package. This will also give you the ability to name them. Instructions are here: Offline maps | CyberTracker Wiki


Hi Alex and Justin,

Thank you for the replies.

Alex, I am using V453 indeed.

The dashed line has disappeared now although I did not export any data as it was for a CA that I just created and was therefore empty. Justin, noted for the “Stop” option under Navigation - good to know.

Whenever I open a map from any of the CAs, it zooms to the last map I looked at instead of zooming to the map of that specific CAs. It is as if my device does not make a difference between all the CAs. I hope that when someone opens its CA, he/she only sees the map from their CAs and not everyone else though.

Hi Marine,

Thank you. I agree this is preferred and I believe that is the expected behaviour. We’re looking into this now and hope to update you soon.



1 Like

Hi Alex,

I was wondering if something was done regarding the above issue? On the app I still see all the maps instead of only the one for the CA selected.

Thank you.

Kind regards,