Phone goes to sleep and interrupts track recording (resulting in long lines connecting track points)

Dear Forum members,

I am involved in a number of SMART projects in Central Asia and recently participated in SMART meetings with participants from many SMART sites from this region. Everybody in the region is using SMART 6.3. A major issue that SMART users discuss is the problem that phones go to sleep in spite of using phone settings to prevent this. When installing SMART Mobile with APK 385, permission is automatically asked to keep SM active in the background, but it does not work; the phones go to sleep and then track recording is interrupted. Most sites use blackview phones, and most BV phones can be set to not close the screen for 30 minutes maximum (only a few models can be set to never close the screen). Therefore many sites have tried to solve the problem by installing a phone app that keeps the screen always on. This works, but it empties the battery and you have to be careful not to touch the screen and do something you do not intend to do.

My question: is there a combination of phone model, phone settings, APK version, SM GPS settings that solves this problem?

Best wishes,

Michiel Hötte
Wildlife Conservation Society

Hi Michiel,

There are several battery settngs in newer versions of android that accomplish this. You have to turn off Intelligent Power Saving and Battery Manager. Exactly where these are differs from device to device.these settings work alsonf with the option to allow smart to run in the background to keep the track log on

Rich

Hi Richard,

Thanks for helping out. I understand what you mean by turn off the “Intelligent Power Saving”. But I don’t understand what you mean with switching off the “Battery Manager”. Maybe you meant that in the battery settings I should switch off “Battery Saver”?

Best wishes,

Michiel

Hi Rich, I checked with one project in Turkmenistan, where BV6600 phones are used, and there is a problem with the phones stopping recording the track although Battery Saver is turned off and SM is in the list of apps for which the battery should not economise.

Are the phones using kiosk mode? Another thing that often happens is that other apps interfere with smart accessing gps.

No, the phones do not use kiosk mode and do not have other apps installed that use GPS.

If there is anything else that can be tried to solve the problem, that would be really helpful.

Even if other apps don’t use GPS they can interrupt the tracklog. Is it an option to use kiosk mode? We have found that this, along with the battery settings already mentioned, is very reliable.

Hi Michiel,

Try following this method.
Tap and hold on the app. And then tap App info

Tap App permissions.

Tap Location

And use Allow all the time for SMART mobile app.