Catastrophic Failures when importing data from mobile device to desktop

Hello all,
I’m using a bunch of Blackview BV4900’s for SMART data collection in the field in Botswana, and recently have come across an issue with some new handsets.

SMART package uploads perfectly to the phone and data collection doesn’t indicate any problems. However, when trying to access the JSON files, it leads to a series of errors, culminating in a “Catastrophic Failure” which then wipes all the data.

I also tried plugging the phone directly into the laptop and importing the files from the device - it says there are no data files to be imported.

When you go directly to the device itself, and find the JSON files in the File folder, they are all there, but it is impossible to select or share them (for example, to attach them to an email).

Going into the phone’s files folder on the desktop also shows that the JSON files are there, but they cannot be selected, copied, cut or pasted anyway.

This action then leads to an error message that says “Unspecified Error” which is followed by a “Catastrophic Failure”. Following this the JSON files are gone, and I can’t find a way to retrieve them.

Trying to import from Archive on the desktop also doesn’t work.

I have tried various iterations of the above on a second mobile device and had the same outcome - no files imported, catastrophic failure declared and data gone!

Can anyone help? Could it be a setting on the mobile device which I haven’t configured properly? Is there anyway to recover files after a catastrophic error (after which they no longer show in the files folder and appear to have been deleted). I have 12 devices deployed and others seem to be working well - JSON files can be attached to emails and sent without issues. I had this issue with the first phone, and then the second did the same, at which point I stopped plugging them in incase it was going to wipe data from all the devices!

Many thanks in advance!
Jess

Hi,

Can you upload the error log here? It can be accessed from the help me ubin smart.

Thanks

Rich

SMART error log_220922.zip (22 Bytes)
Hi Rich,

I’ve uploaded a zipped error log file - it was too big otherwise.

In case it’s any help, it was 12th September when I was trying to upload these files.

Thanks so much,
Jess

Hi Jess,
I have a few questions to help with further troubleshooting. It seems like it’s an issue with the computer or the devices themselves, likely related to permissions, but here are some things we can check.

  1. Which version of SMART and SMART Mobile are you using?
  2. Are you able to import SMART data with the same devices on a different computer with SMART installed?
  3. Are you able to process SMART data from other devices on the same computer?
  4. Are you able to successfully transfer any other files from the devices to your computer?
  5. Is your USB connection set to File Transfer Mode when connecting the device to your computer?
  6. Could there be an issue with available storage space on the device or computer?

It appears that the error log .zip file you attached is empty.

Thanks,
Matt

Hi Matt,
Sorry for the delay in replying and thanks for your useful questions. To answer them to the best of my knowledge:

  1. I am using SMART 7.4.0 and SMART mobile 1.0.400.
  2. No, no computer on our server works.
  3. Yes, I am still able to download, copy and send JSON files from older devices and import their patrols into my desktop. This has only been a problem with new devices (Blackview and Samsung so far, running on Android 11 and 12 respectively).
  4. Yes, I can send and download photos, files such as Word docs etc. to and from the phones.
  5. Yes, the USB is set to File Transfer mode.
  6. I’ve tried this with brand new, out-of-the-box devices where storage isn’t an issue.

As you suggested, I’m thinking this is a permission issue?
In the settings on the phones, under the Apps Permission Manager, I notice that SMART is listed under the “Allowed access to media only” section - not “Allowed to manage all files”. There is no option to allow full access - the only options listed for SMART are “Allow access to media only” and “Don’t allow”.

I’ve googled and tried to understand the issue with permissions, file managers and Google’s scoped storage, have installed several other File Managers (I can now “see” the files in Android->Data->org.cybertracker.mobile.smk->files->SMARTdata, but I cannot copy, move, open, share them). If this is the case, is there any workaround for SMART apps? I’ve uploaded apk version 400 onto the phones - is this version out of date now?

When I plug the device directly into my laptop, and import within the SMART desktop (Field data->SMART mobile-> Import) it simply says there are no files on the device and erases them.

The error log requested is a huge file, any suggestions on how I can upload that here if the zipped version isn’t working?

Thanks for any advice!
Jess

Hi Jess,
I’m not sure what’s happening there and I haven’t seen this issue reported in SMART 7 testing so far, so we’ll need to escalate this to have the developers look into it. I will send you a message with the form to submit SMART 7 testing issues.

As for the error log, if you could just copy the portion that contains information including the last time you reproduced the error, that would help reduce the size.

Regards,
Matt