Conservation Area Boundaries Error

Hi. I’ve been having the same problem on three different computers (and just realized other people have been as well). It goes like this:
When trying to upload the conservation area boundaries, after selecting a shapefile and accepting, an error message appears which only says “null”.
Then when you close the boundaries loading interfase you can’t open it ever again.
Already tried wit different shapefiles too.
I’m attaching screen prints and the error log.

(Pseudo solution: since the shapes get loaded anyway, we are loading them all in one try, so when the dialog closes and doesn’t open ever again, the layers remain. Only catch is it’s impossible to change them afterwards)

smart boundaries error log.pdf (105.6 KB)

Hi Juan,

I think this is likely 1 of 3 possible issues:

  1. The shapefile - does the shapefile load into other platforms / software without issue? If no, then there’s a problem with the file.
  2. The projection - is the shapefile created under the same projection as that set in SMART?
  3. The language - it could be an issue with SMART trying to read the attributes of the shapefile

I think to understand which issue it is we’ll need to interrogate the layer in a GIS platform (e.g. QGIS).

You can share the shapefile and I can look into it from my side, if you like?



Hi Alex. To 1 and 2, yes that’s checked.
To 3), I’ll share the two the shapes i’m using. But I’ve also been trying with shapes created ad hoc just for the test (with same results).

Also, note that the layers do get loaded and appear in the map. Just that you can’t open the boundaries dialog again once you closed it.

Limites del (2.5 KB)

Thanks a lot!

It’s working as expected from my end. I am able to display the layers and re-open the boundaries window as normal.

Is this a recently installed version of SMART? Maybe we can try backing up and re-installing the software?

Failing that, we’ll have to escalate the issue as I can’t replicate it. If so, would you be able to share a backup of your database and login information, directly?

But I think re-installing may solve the problem.

Kind regards,


Ho Alex. Yes I tried reinstalling. I sent you a private message with a username and password for connect and set you as admin for the CA.

Thanks a lot