Copying Data Model from Existing CA - Error

Hello, I am trying to use a data model from an existing CA to upload to a different CA, and I keep getting an error. This is the error that I keep getting. Is there something I need to do to the original data model?

Hi Maggie,

Is this a new CA you’ve created with no existing data model?

Could you please do the following when possible:

  1. Export the Data Model from the existing CA to XML
  2. Attempt to import the XML using the option “Import a custom data model” to the CA you are trying to copy it to to see if this works
  3. If so, there seems to be an issue with this function, please share the following information:
    3a. SMART Version
    3b. An export of the error log (file > view error log > save)

Thank you.


Hi Alex,
errorlogdatamodelCA.txt (729.3 KB)

Yes, it is a new CA with no existing data model. I have also already tried exporting the data model to XML, but it quits when I try to upload it and I get the same error as when I try to copy the data model from the existing CA. I have SMART V. 7.5.7 and the error log is attached. Thanks so much for the help!


Hi Maggie,

Thank you. I’ll submit a ticket for this.

In the meantime you can try exporting your CA then re-installing SMART (on local storage C or D drive) and repeating the process to see if the issue is being caused by an error when the software was installed initially. If you manage to do this please let us know the result.



Hi there, can you post or private message me the XML data model export please? It appears there is a duplicate key in there somehow (it shouldn’t be allowed), we can probably find it if we have the XML itself.