Desktop <-> Connect sync problem

Hello all SMART programmers!
I started using cloud Connect, started with new Data Model on SMART Desktop 7.5.6, synced this to cloud Connect (7.5.3) at (SMART Connect - Login), and it worked. However, when I try to set the only one CA as default, nothing appears in the drop-down list. Further, when some test package created by SM is uploaded to Connect server, the package disappears from mobile device, but does not appear as package on server and it it is not “seen” by SMART Desktop 7.5.6.
BTW, I applied for the upgrade of cloud Connect so that I can use Desktop 7.5.7. Can someone take a look at this server, ideally upgrade it and make it working at te same time? Currently it is only me who is trying to develop one new CA on it, so no any disturbance will be done.

Our other Connect server (ver. 7.5.3 on premise) works well with Desktop 7.5.6


Hi Josip,

Is the CA newly created? If not, have you tried to download the CA from your connect server or import it from a CA backup? If you cannot see it in the drop-down list, it might mean it hasn’t yet been imported.
With regards to the Connect packages. Are there any errors that you receive when you export the package onto SMART Connect from your SMART desktop? Is the behaviour the same when you export the same package directly to the device from your SMART Desktop? Are you able to see the mobile package when you access your connect server through the browser?

Please note that if you are attempting to get a package that is on SMART Connect, you won’t be able to see it on SMART mobile if you select “SMART Desktop”. That option will only load new packages that have been exported to the device.

We shall have someone from the team coordinate your upgrading process of connect to 7.5.7.



Hi James,
I will try to answer all your questions.

  1. To create new CA, I used the old one from our on premise Connect server, adapting it. Maybe I should have started from scratch?

  2. I tried back and forth import<->export, backup-restore between two Connect servers, but the CA under construction seems to partly works (with described glitches) only on cloud Connect.

  3. The CA has been imported to cloud Connect, I see it on the list of CAs list , but not in the drop-down for default CA and not in “Conservation area” drop down of “Data Processing Queue”.

  4. There are no any errors when creating and exporting SM packages which then gets installed from Connect to SM. I do not install SM package by connecting mobile device with desktop PC where SMART Desktop runs.

  5. There are no any errors when JSONs from SM are uploaded to Connect. They just disappear on the way from SM->Connect, and they are not visible in Connect through browser.

  6. I do not try to see the JSON package on SM, once they are uploaded to Connect. I know and look for the functionality of some future versions of SM where there will be option to retain the data on SM. After pressing “EXPORT DATA”, the message from SM is different. Instead of “All data has been uploaded” I get: “Data is ready for import from the desktop”.

  7. I can create an Administrator account on the Connect for the purpose of 7.5.7 upgrade.


… and I have to add that I am cornered in the situation of making the CA available to 18 project partners in the next ten days. My assumption was I can do it, but I did not expect any technical hurdle using the versions of the system which is out for almost a year. So please can anyone do something rather soon?! Thanks!

Dear all!
With the help of James, one obstacles was resolved and I resolved another one this evening. It was a matter of ticking (to me) obscure tick boxes a two different and “distant” places and enabling some options. The system works, and it seems I can proceed with my task.
However, the little glitch of Connect 7.5.3 (empty drop-down for choosing the default CA), remains. Waiting the upgrade…
Thanks James!