Error in patrol attributes


While updating custom patrol attributes, I suddenly got an error message and wasn’t able to proceed any further. The error message is as follows:

An error has occurred. See error log for more details.
class java.lang.String cannot be cast to class (java.lang.String is in module java.base of loader ‘bootstrap’; is in unnamed module of loader org.eclipse.osgi.internal.loader.EquinoxClassLoader @2d6a0766)


Can you provide the error log from the help menu?



Ok I mailed it to you now. Thanks a lot!

I have a few questions to help with troubleshooting:

  1. Did you add or remove any custom attributes before getting this error?
  2. If you exit SMART entirely, relaunch it, and go back to the custom attributes, does the error still occur?
  3. Could you add the error log in a post?


Hi Matt,

To answer your questions:

  1. It occurred after I added some custom attributes.
  2. I did exit SMART and relaunched it. I even reopened on a previous version of SMART 7.5.1. But still the same error.
  3. I tried to enter error log in response to Richard’s query, but too many characters for a post. Is there an alternative?

Thanks a lot!

You can use the “upload” button on the tool bar (the arrow pointing upward) to upload a file when you make a forum post.

Ah… apologies. Please see the attached error log.

.log.docx (306.2 KB)