Error upgrade CA to smart 7.5.6

Hello community,
I am upgrading CA from SMART 6.3 to version 7.5.6, I have this error.


Then the application no longer starts,

I hope you can help me, thanks

Hello Catalino,
I am following up with our development team to help troubleshoot, and I have a few questions that will help us:

  1. At what point during the upgrade did you receive these errors?
  2. If you restart SMART desktop (and your computer if needed), do you continue to get the errors?
  3. Are you able to send the error log?

Restarting typically resolves this kind of problem, but hopefully we can figure out the root cause and address it.

Thank you,

For future searchability, here is the translated text of those error messages:
restore failed error creating temporary copies of existing data

Could not connect to the database. Check that another instance of SMART is not running and try Unable to acquire JDBC Connection

Hello Matt,

The first error (restore failed error creating temporary copies of existing data
.\data\database\smartdb\seg0) exits when trying to update the CA from version 6.3 to version 7.5.6, it does not finish updating and the error appears.
The second error comes out when trying to open the software and does not allow the program to start.

2023-01-12 14 02 20

I have restarted the laptop and still get the same error.

Thank you,

LOG.txt (1.3 MB)

Thank you, that is very helpful. I’ll let you know as soon as we have more information.

Thanks Matt,
I will be waiting for your answer.

Hello Catalino,
Based on the log file, it looks like the data folder is either missing or corrupted. Ideally SMART is supposed to revert back to the original data in this case, but if the first error happened due to lack of disk space that might be impossible.

The recommended solution is to start over. Unzip SMART7, restore your SMART6 backup, but make sure you have enough disk space.

Hi Matt,

I still have the problem, I share a link to a video so you can review it.
Thanks you

Thank you, Catalino. I shared your video with the developers, and they provided some next steps.

  1. Would it be possible to get a copy of all the log files? You should be able to find them in the workspace/.metadata folder, and anything with .log in the filename would be helpful.

  2. Would you be able to share a copy of the file that you are trying to upgrade? That would allow us to try it out ourselves and further troubleshoot the problem.

Feel free to send me any files via private messaging so they’re not shared with everyone.

Thank you,