Invalid Number of Rows Error when syncing to Connect - v7.5.2

I keep getting the following error when I try to sync with SMART Connect (screenshot attached)

Error processing work item java.sql.SQLException: Invalid number of rows updated

SMART Connect 7.5.2 Error

Hi Nick,
I’ve seen that error a couple of times when the desktop and Connect get out of sync – such as a conflicting change getting made on multiple desktops or a patrol getting edited when not all data was processed. I’ve been able to resolve this in the past by refreshing my desktop from Connect (Connect > Advanced Options > Replace CA with CA from Connect). I recommend saving a backup before doing so, and if you made any changes on the desktop that haven’t been synced yet, you may want to save them off first and reapply them afterwards.

Let me know if that takes care of it for you.