New package on server but not visble in the descktop

Dear Colleagues,
We have generated a new patrol packet, which we have exported to different devices and which works correctly as we are collecting the field data on the descktop that goes through the server first.
From another computer with a different account with administrator rights, it turns out that we cannot see the new patrol package.
Can only the person who generated the package see it? I seem to remember that this was not the case before. We tried reloading the conservation area but it didn’t fix the problem.
Could it be a bug, am I doing something wrong?


Jose A

Using: smart 7.5

On the first computer, have you made sure to sync the database with Connect? And on the other computer, have you made sure to do the same?

If you sync up to connect and then the second computer syncs to the most recent version, the patrol package should be present.

@drew.cronin I came here to report the exact same bug. We tested it on my computer and in one in Lao. The data in the data queue was there when using a browser, but nothing was there when accessing Connect through SMART Desktop.

1 Like

@DiegoM or @jblanco can you provide a short video demonstrating the issue? And, ideally, an error log from the two computers you tested this on.

@drew.cronin …This is a little different issue that I reported, but probably the origin of the problem is the same. However, i am suffering also the same issue that @DiegoM reported.

Server view from browser (full of patrols data)

Smart desktop server view (empty)

Additionally when I tell the server to synchronise, it tells me that everything is already synchronised, but it doesn’t seem to be correct. Because from one week ago there are new patrols in the server that are not downloaded to the desktop

However, the problem with the package not being displayed on a computer other than the one that generated it already existed before this connection issue happened. For a week we received the patrol data that was collected with the new package.
Jose A

The bug I am talking about corresponds to the first two pictures that Jose posted. Me and another administrator of the same CA had the same issue. However, we both created independent incidents and we were both able to process each other incidents. In SMART connect, these incidents were not shown if using the SMART DEsktop browser.

@DiegoM @jblanco We had a bit of an internal discussion and are still a bit unclear, but came up with the following thoughts:

  1. We believe the integrated browser in Desktop is using the old Internet Explorer. Can you check if the package is visible when using a different browser?
  2. Package thing sounds like a syncing issue? No errors? I tend to advise people to use a proper browser and not the server interface from within the software myself.
  3. Are you certain each of the computers has the appropriate permissions?

Let us know and we’ll keep investigating as necessary.

@drew.cronin I can say for sure that everything is working just fine except for the SMART Desktop browser. I created an incident with SM, it went to connect, it was visible in connect (when using another browser than the SD one), and it was processed on the other side (another SD instance in Lao) without problems. Then, we did the same exercise backward. It worked just fine. What we both had in common in our corresponding SD instance is that the data were not displayed in SC when using SD browser. Both of us were able to see the data using a non-SD browser in SC (in each of our individual accounts for the same server).

I agree with @DiegoM diagnosis. In case it was a problem associated with the Spanish translation of the server or SD, I have reconfigured my computer (windows) using the English language, so that both the SD program and the server appear in English, but the problem with the SD browser remains. It is not possible to view the data packages uploaded to the server using SD.

However, I had other additional issue that i will try to document in another answer in case it would be useful to other users.

We’re looking deeper into this and will circle back soonest.

Drew T. Cronin, Ph.D.

The problem with the server and the packages I think we have been able to solve it, but we don’t know how it was generated. We are sharing our solution in case it might be useful to other users.

  1. Three users with administration rights, one of them (administrator 1) made improvements and changes to the data model (version1) and generated new version (version 2) and new patrol packages.
  2. Everything seems to work correctly, the new patrol pack is exported and uploaded to the server, the data collectors in the field start uploading the data to the server using this package. The other administrators (2&3) receive the data from smart mobile without problem. But we notice, that administrators 2&3 who did not generate the package cannot view this patroll package on their SD. Not knowing why, the data stops downloading (7-11 June) and admin 1 has synchronisation problems.
    To try to fix the problem with the data not being downloaded, we updated the conservation area from connect to the SD, but we lost all the changes we had previously made to the data model (version 2). The new packages that are still on the server are not downloaded. It looks like we are back to the version 1 we had before.
    To solve the problem:
  3. We load the backup copy of version 2, saved in the local directory
  4. Clone the conservation area and generate a new conservation area and new packages taking advantage of the configurable models that we had already designed.
    The data we had already downloaded were exported in a suitable format for analysis, so it does not seem that we have lost information.
    This procedure solves the data collection problem we have, but we do not understand what caused it or how to prevent it from happening again.
    I hope the procedure is well understood

We are just starting using SMART Connect with SMART 7. What I have seen is that it takes a bit of time for the patrol data to apear on the data queue.
The other problem that we had is that we have lost data as we did not have SMART Connect yet in one of the mobile devices. The source of it was that the SMART mobile app did not have the authorization to write on the internal memory of the phone, then my colleague using the phone have hit the “Export” choice on the SMART mobile. After “clicking” or hitting that, the mobile app asked for authorization and he hit “yes” for all of it. The data was still visible at the “History” part of SMART mobile before he hit the “Export”. Now, the data disappeared. There was a JSON file of 60 Mb created but the patrol data was not in it when they imported it into the SMART desktop (the usual way they do to import patrol data).
Best wishes,

Hi Angelo,

For the SMART Connect data upload, this is likely a connection issue.

For your offline data, can you please check (1) in the package on SMART Mobile settings > Exported Data to see if the data is visible in this list or (2) plug in your device and check to see if the patrol data is visible; go to the directory: Android > data > org.cybertracker.mobilesm > files > SMARTdata

Failing this, you can export a bug report from the device and share it here so the developer can look into it.



1 Like

Hi Alex,
Thank you for this!
I have found out that when exporting the package from SMART Desktop to SMRT Mobile and SMART Connect, there is a tick box to confirm that the SMART mobile can upload or send data to connect. Once activated, sending data to connect from the mobile device is working well.
If SMART connect from the mobile device is not working, we can still recover the data (FYI we are using QMART mobile 3.85 and 4.65). In the setting button, there is a way to share your patrol data with other means i.e. using Bluetooth or Xender or Google Drive or by email or MS Teams (whatever service/app you have on your mobile device).
Thanks again,