Not able to force sync in Smart 7

Hi all, I have just noticed something for the first time on my SMART 7 and wonder if it is a setting that I have set incorrectly (although I have looked through everything that I know of that could affect this and cannot see where), or if it is an issue with the CA and server connection. There were some changes that I did on the CA on my desktop and wanted to then make sure the changes were sent to the server, however, I suddenly noticed that I no longer have the option to force a sync as I did previously on Smart 6. Current options are listed but are greyed out (see below) If this is a setting I need to change, please let me know what and where. Alternatively, if anyone have any suggestions as to how to get this sorted and working again would be greatly appreciated.

Screenshot 2023-04-25 at 12.35.24

Hi Debby,

This shouldn’t be the case for a CA connected to a server with any settings. It appears to be a loss of connection between your CA and Connect.

Can you try re-configuring the server or re-downloading the CA from the server? This should re-establish the connection. (of course, make sure to backup / export any local changes first which can then be reimported).



Thank you Alex. I will certainly try that. Connectivity with the server seems to be a major issue - I have been battling with connectivity issues between Smart Mobile and the server for a while now and now between Smart desktop and the server as well. Oliver is trudging through smart mobile bug reports for me to see if he can work out what the issue is that keeps re-occuring there (although they all seem to be connectivity related). If the issue is happening on both Smart Mobile and Desktop, would the issue not then be on the actual server instead?

I just want to find out - will it work if I do it the other way - ie if I delete the CA on the server and rather re-upload the server. The reason I ask is that one of the factors that initiated this process is that we were trying to download the CA onto a colleagues computer and we have been unable to do so - it keeps hanging. I dont want to be left in a situation where we have no access to the CA if I cannot get it re-downloaded onto my computer as well - then we are properly in the poop. However, if I do it the other way, then I at least have access to the CA to continue working with if things dont come right. I am also a little confused as to the CA and server not being connected as I am still occasionally receiving observation reports from Smart Mobile so there is connection occurring?

Hi Debby,
I already had this sync problem with local desktop, when my network went down. I then had to restart SMART Desktop, when network was available again. That fixed it for me

Hi Debby,

It’s strange you’re still able to connect to some aspects. It seems Oliver might have had the same issue so perhaps this would work for you.

There’s no real issue of deleting the CA from the server and re-uploading if you’re the only person working on the database. The issue would be if, as it seems you do, you have multiple people working on the database as if you delete the CA from the server it will cause all other desktops to lose access to the CA. Then, you may have some trouble getting everyone re-connected. As a rule of thumb, I generally say only delete the database from the server if absolutely necessary as it has less of an impact on overall workflows and other users.



Thanks Alex. At present I am the only desktop user connecting to Connect (apart from the Smart Mobile devices obviously). I am wanting to get set up another user on Desktop and it is through this process that we have now identified these problems.

On his computer, the download just hung and did not seem to progress - despite leaving it for almost 2 days to try and download. I have just tried it on another computer and I get the following error

If I am understanding it correctly, again it seems to me that the error is on Smart Connect not on the desktop side. I have now experienced connection problems from my desktop, as well as this additional desktop with a new and clean installation of SMART 7 as well as numerous difference Smart Mobile and Smart Collect devices. The common denominator with all of these is the Smart Connect server firstly and looking at the message above, again it tells me the server is not communicating properly with the desktop? Would this make sense? If it is the server/ Smart Connect that is creating this issue, any suggestions as to how to fix it? My CA is on the Smart server.

1 Like

Thanks Oliver - I have restarted numerous times and sadly no change at all ??? As per my message to Alex as well - I have also tried to download the CA onto a new desktop however it seems I am getting a connection error from the server/ smart connect

Hi Debby,

this seems to be a bug.

I was able to replicate this problem, when uploading a big CA to SMART Connect server.
When uploading a big CA or if your network is not very fast the upload itself might succeed, but the extraction of the compressed data on the server is taking to long.
Uploading is a three step procedure:

Build a compressed CA export file in SMART Desktop
Upload this Zip file to the server
Unpacking and importing the zip file on the server.

When the timeout is triggered during step 3 the CA gets eventually imported into the server, but SMART Desktop still thinks, that it’s not on the server.

I was able to reset the internal table the keeps the status of the Conncet server connection, but that is a bit difficult to do and requires some database knowledge.

The best option in the moment is to check the server, if the CA was successfully uploaded and then use in SMART Desktop the function to replace the local CA with the one from the server.

I will file this as a bug for the current version of SMART Desktop


Thanks Oliver – really appreciate this.

My problem is that the option to replace the CA with the version on the server is not available to me – it is currently greyed out? I have also tried downloading the version from the server onto 2 other devices – so a new and clean download and it wont let me – it keeps giving me an error and tells me it times out waiting for the server to respond.

Any other thoughts?

If you want I can try to guide in how to fix it on your machine.

Oliver Adolph

Technical Operations Lead
Smart Partnership

Hi Oliver and Debby,

In previous versions of SMART there was an issue in some cases where downloading the CA directly to the software didn’t work (showing errors or stating that there was no CA on the server). A work around in these cases was to download the CA directly from the server via your browser (using the blue download icon) and them importing the CA and checking the Connect configuration.

That said, I’ve not seen this in 7.5.6. So, I’m not sure this will work in this case but it’s perhaps worth a shot while Oliver looks into it in more detail.

Thanks, both.


Thank you so much Alex. Oliver has access to my CA at present so hopefully he can find a solution and get things back on track. Really really appreciate both of your assistance

Thanks a lot Oliver. I had the same problem. Thanks Debby for highlighting this. I see that I am not even able to download from connect again:

I also have Version Would you like me to directly send my Error log to you Oliver? Regards

Hi Peter,
yes, please send me your error log. I might better see what might be going wrong from the logs…


1 Like