Remove rows or columns with no data


Id can’t seem to figure out how to remove rows with no data within a “Cross Tab” table.

In Reporting, in the “Outline” panel, I first loaded in a query into my data sets. I then created a “Data Cube” to import this data query. I added a “Cross Tab” to the report and dropped the “Data Cube” in the “Cross Tab”.

The table gets populated, with rangers as the rows, and the number of patrols/distance patrolled, etc. as the columns. However, there are a lot of rangers that do not have any patrols and I’d like to remove these empty rows (see example image from report).

How can I format the Cross Tab so that it only populates rows with data?

I did notice that in the properties there is a “Empty Rows/Columns” menu, but I can’t seem to figure out how to enable it. Please see the attached image.

Hi Philip

To remove the empty row, you should add computed column into your data set and useexpression to SUM data from one row.

this an example

Then, on your report layout, add a filter to exclude your empty row.

Lili Sadikin

and here the result

Hi Lili

Thanks for the response - this works perfectly!