Reports & Data Cubes: number of attributes in a query and on available fields dont match


I am doing a report and used a data cube to organize my information. First I did an observation query about bear sightings, and I got like 18 related attributes. However, it is weird to me that when I used that query as a “primary dataset” for the data cube, it displays a lot more than 18 attributes in the “Available fields” and are not even related.

Am I using the data cube incorrectly, or is there any mistake with the query ?

Thanks for your help

Hello Jackie,
In the query properties, I suspect that you have it configured to ‘only show columns with data’, which may only include 18 attributes when you run the query, but for purposes of the data cube the query could include data from any attribute. If you just want to include certain columns, you can go to your query and click the query properties link. You can then uncheck ‘Only Show Columns With Data’ and select the specific columns you want to include.

Hey @matt.hron,

I attach some pictures of my query

as you can see I only use three attributes for the values.

In the data sets it seems correct

but when I use the data cube I see all categories and attributes of my data model

So, for data cubes we can use our queries combined with any other variable of our data model?


Hi Jackie,
I’m not an expert at data cubes, but what I was referring to is the configuration to define which columns are available to your query. If you go to your query and click the blue ‘query properties’ link on the right, it will open up a window where you can define which columns to use.

If you’re seeing columns you don’t expect, the first thing I would check is that you specify here which columns you want to include instead of including all columns with data.

1 Like

I didnt notice that option, thanks @matt.hron :slight_smile:

If the above also doesnt work the way you want, manually choose (In the Query properties) the columns you want displayed then that will come across into your report

We also made a video if thats helps

1 Like

Great video! Thanks @djoachim