SMART 7.5.4 Imported Waypoint/track time converted to UTC+0

Hi all,

We have an issue where track and waypoint time were converted to UTC+0 from UTC+8 when import into SMART from GPX file. The time setting in GPX file and device (PC) were confirmed to be UTC+8.

Attempt to solve the issue:

  1. Tried on multiple PC. The problem remain.
  2. Using a fresh download SMART example CA. The problem remain.
  3. Tried multiple GPX files. The problem remain. Using the same GPX on SMART 6.3. It works on SMART 6.3.
  4. Changing/Reset Time setting in device and restart PC and re-import into SMART. Imported time converted to UTC+0 no matter what setting in the device (ie UTC+8, UTC+0, UTC-8).

If anyone encounter any similar problem using SMART 7.5.4? It would be great if anyone have any idea what might cause this problem and how to solve it.

Thanks in advance.

Original GPX File with time UTC+8

Original Time in UTC+8 in GPX file

Time converted to UTC+0 when imported into SMART 7.5.4

After Import into SMART 7.5.4

Hello,

Are you also using SMART Mobile? If so, could you tell us if the issue happens when using this mode of input also?

Would it also be possible to import the GPX file(s) to another software platform (e.g. QGIS) to see if the issue is definitely with SMART and not the computer or GPS device?

This may also help us to isolate where the issue is occurring (i.e. reading of GPX files or another software time issue).

If you prefer, please feel free to attach the GPX file and we can review it.

Thanks,

Alex

Hi Alex,

We are not using SMART Mobile at the moment.

We are using Mapsource to edit our GPX prior importing into the SMART. We are able to add GPX files into GQIS but notice some difference in the attribute table.

In Mapsource
GPX 2016: Date and Time show in Comment
GPX 2016 in Mapsource Waypoint Properties

GPX 2022: Date and Time show in Last Modified
GPX 2022 in Mapsource Waypoint Properties

In QGIS,
GPX 2016: Date and Time show in Comment and Description

GPX 2022: No Date and Time in the attribute table

In SMART
Both GPX file works normally in SMART 6.3.
GPX 2016: Unable to normally import into SMART 7.5.4 using All Import/ specific date. Need to use the Select waypoint option and the time after import is set to 12:00 AM
Old GPX

GPX 2022: Able to import into SMART 5.7.4 but Time was convert to UTC+0 as shown in previous post

Attached here are the GPX files use in troubleshoot.
https://drive.google.com/drive/folders/1Uyiz2CDlhZCskzMWY69XJVeyeZNzB6jz?usp=sharing

Thanks.