SMART connect error when syncing

Hi everyone.

I am currently experiencing a “Download Error” when trying to sync with SMART Connect.

The server was recently upgraded to 7.5.7 to match the upgrade of the desktop version. Since this update I have been getting an error when trying to sync all changes with SMART connect.

Error: Unable to apply changes from SMART Connect.
Please see below screengrab for a more detailed description.

I want to find out what are these items, and how do I delete them to redownload them from SMART Connect?

Thank you.

Hi Alex,

Do you have multiple users accessing and editing the database?

Is it possible different users are editing the same items (i.e. processing data)?

If so, this may be an issue of multiple users trying to edit the same information leading to a conflict when trying to upload / download changes. To avoid this it is best practice to have some procedures in place regarding who is editing what and when.

We should also be careful to ensure users synchronize with the server upon logging in and logging out to ensure you are working on the most up-to-date version of the database.


Alex W

Hi Alex.
Thanks for your response.
No, I am the only person who has access to the desktop system as well as the SMART connect system so there must be some other fault. Any ideas?


Hi Alex,

In this case the error is quite clear as to what is happening i.e. the local and connect versions aren’t matching up. In this case it looks like it is specifically an item on a report that is not matching up.

If not through multiple users this can occur sometimes when synchronising with the server isn’t being done as regularly as needed or simply that a sync failed due to connectivity issues previously.

In these cases the safest course of action is to (1) export any recently imported data (i.e. last month of patrols, recently designed queries/report templates etc.), (2) perform a system back up (File > System Backup) then (3) do as the message instructs - Connect > Advanced > Replace CA with CA from Connect.

This will erase the copy from your SMART desktop installation and replace it with the version on the server. You can then check if any data is missing and import from the exports you did in step 1.



Hi Alex.
Thanks for the detailed response once again.
That seemed to be the problem - the desktop and connect versions were not synced for some reason, which I think was because of the upgrage to 7.5.7 on desktop and an older version of the server.

I tried your method, but the system was completely outdated and a lot of the local changes were not present - including config models Id build, and changes id made to the data model it self. I then tried to install the backup and a lot of the changes were still not present. I also tried to merge the data models from a previous system backup to rectify this but there were problems with the translations on my system. I opted for the reverse, first backing up my connect system, and then deleting the CA on the connect server and reuploaded it from the new 7.5.7 desktop version and everything is syncing up nicely now.

Thanks for all the help.

Perfect - thanks for the explanation, Alex.