Track and Feature Processing Errors

Good Afternoon All,

I know this issue has been posted about previously but none of the suggestions provided on the various forum threads have worked for me as I believe we have multiple issues at play at one of the sites I manage.

We are currently using SMART Mobile (V1.0.453) deployed on Blackview BV5200 Pro devices for the data collection processes at the site. We are processing this data through SMART Connect to SMART Desktop 7.5.2

Device Specs

The first issue we have, which I believe is device based is that the track points are not recording every 5 seconds during a patrol as they are set to. In most cases they record for a short period of time after the screen is turned off and then do not record again until the phone is woken up to record an observation giving us lots of straight lines in our patrol tracks.

The device settings are as follows:
Battery Manager - Off
Power Saving Mode - Off
Bluetooth Scanning - Off
WiFi Scanning - Off
Google Location Accuracy - Off
SMART App Location - Allowed all the time
SMART App Display over other apps - Allowed

The second issue we have is we receive an error message when processing the last JSON file of every patrol. The file seems to complete processing successfully after the error window is cleared so there is no opportunity to re-process the file as I have read as a possible solution in separate threads.

Trac Processing Error 1

Error Message

I think is is important to point out that this issue is only occurring at one of the 7 sites we manage. The tracks and data processing function at all the other sites works fine.

Is it the same phone at the other sites?

Hi Rich, no we have a variety of different devices across all our sites but this is the only site with the BV5200 PRO devices. They run on android 12 so I’m wondering if that has anything to do with it?

Hi Nick,

I’d be suspicious that the issue if the model of phone then. Even within manufacturers there are so many different version of firmware, hardware, etc. that it is difficult to ensure they all work. One useful test would be to get one of the devices you know works at another site and test it here. I would guess this is the issue and that it is the particular version of Android or the hardware on these particular phones, rather than Android 12 or SMART. In years past when we saw this issue it was due to settings or configurations on the phone (often not user configurable) that caused the issue.

Hi Nick,

In additional to Rich’s useful comment I want to add that I had two identical devices (also Blackview but a different model), one had an issue with the track when the screen was off, one didn’t. Upon setup, I accidently did not provide the full permissions to SMART Mobile and then adjusting the permissions didn’t seem to work. What did work in my case was a full factory reset of the device and reinstalling the app. I wish I could explain why this worked as there doesn’t seem to be any logic to it but may be worth a shot.

The final JSON not processing is likely an issue with the “end patrol” being processed before the final track point which then has nowhere to be added. Usually this doesn’t cause any loss of data. Could you confirm this is the case?



Thanks Rich and Alex,

We did recommend for this site to purchase a model that we had used successfully at other sites but the supplier in RSA only had stock of the BV5200 PRO so now were stuck with 30 of these devices and so need to try and get them to work!

I will get them to try the factory reset option but just from a process of elimination purpose please if we know of any other users who are using SMART on Android 12 without this problem occurring?


Hi Nick,
To add to Alex’s comment about the last waypoint being after the end of the patrol, there’s a known issue where the last waypoint of a patrol might not be processed because it is using milliseconds for the timestamp, but the end date of the patrol is rounding to the second, so it can be cut off due to being milliseconds after the end of the patrol. I suspect that is the case here, in which case if you change the patrol end time to one second later it should file correctly. I believe a fix is in progress for that issue.

Thanks Matt. I believe the main issue regarding the trackpoints is deice-related so the processing error is not a problem if it’s being rectified.