Track of a patrol in a report

Hi there,

how can I paste the data of the track of a specific patrol into a map of my report?

Hope there is a way

You should create Patrol query first, and add that query into your report data set.
Then you need to add the map layer and choose that query.

I am running the report with the ID patrol as the report parameter. I did the patrol query and chose it in the map layers but it only showed one of the multiple tracks of the patrol I want :confused:

Hi Jackie,

Would you be able to detail what you’ve done with regards to the query design and linkage to the report so we can try to determine the problem? This is a common feature used so there shouldn’t be any bugs expected here.

I’m a little confused in that you’re trying to display multiple tracks from a single patrol ID. Generally, the patrol ID is for the whole patrol and the track should mirror this, assuming the timeframe of the report is correct / overlaps with the patrol time.

Perhaps screenshots of the query and the report map will help in understanding the issue.

Kind regards,


Hi Alex,

this is how the map looks like in my patrol

and is the result of multiple tracks

I did an observation query for logging

Then, I did a patrol query based on “activity”, which have logging

I added both queries to the map

but when running the report the track is not complete

Thanks for your support

Hi Jackie

To show all of your patrol track, please don’t use any filter to your Patrol Query.
Report will filtering the patrol track base on your Patrol ID Report Parameter.



Lili Sadikin

Hi Jackie,

Is it possible the date parameters of the report are impacting this? I.e. is one leg of the patrol outside of the date parameters of the query you’re running?

If so, this is expected. The tracks are broken up by each leg, so it will only display the “leg” that occurred within the set timeframe.



I got this error if I use the query without any filter

Hey Alex!

All the tracks are on the same date. Additionally, I expected to see all of them because my report parameter is the patrol ID


No idea why, but another person tried to do the same process I did and got the correct result

Thank you very much for your support.

Hi Jackie,

The only thing I can think of is checking the dates of the query. Not the date itself but changing the parameters from “patrol start” to “waypoint date” or vice versa.

The other thing you can try is running the query for the specific item which is breaking the track into different legs, for example: (1) Patrol ID = 0001 + Transport type = foot, and (2) Patrol ID = 0001 + Transport type = vehicle. These should appear as separate records in the patrol query so maybe adding them as separate map layers will work.



1 Like

After remove the filter from query, then you need to save it.
Edit your report, then update query binding, try again to run your report.