Download error - connection failed

Good morning,

On one of my CA, it is not possible to expor data anymore on SMART Mobile. I get the following message: Error. Connection failed. Please try again later.

I first tried to re-export the package on SMART mobile and it worked.

I then tried to sync changes to SMART connect and got the attached message.

I don’t know if there are any links, but it is on that CA that I added labels to the road names on the map but it did not appear on SMART Mobile and I have asked help about it as well.

Hi Marine,

Can I ask which version of SMART you are using?

I believe this “RESTEASY” message is a known error which should be removed in either 7.5.7 or the upcoming 7.5.8. In the past, this error is a temporary block and reattempting the process usually works.

The error regarding SMART Mobile looks like something else. Just to clarify, you’re getting the error message on the SMART Mobile application and you are unable to upload data from SMART Mobile to your database?

Provided the package is correctly configured (you can check the package settings on SMART Mobile) then I would think this is an issue with your Connect server.

If you’re using a Connect server provided by SMART can you please share your URL.

For your SMART Mobile map issue can I clarify if the export of the package was successful and whether you exported via Connect or cabled connection? If the former, it might be a related issue.



Hi Alex,

Sorry for the slow reply.

I am using SMART 7.5.7.

I was able to sync all changes to Connect now and to re-export the package to SMART Mobile via Connect but I still get the error message on SMART Mobile application “Error. Connection failed”. I am unable to export data from Mobile to Connect.

Here is my connect server:

Hi Marine,

OK - thanks. It sounds like an issue with the server in that case. I’ll see if someone can look into this for you.

I’m just wondering if it happens with different packages or just this particular one? If the latter, it might be either an issue with the package (in which case, recreate the package and try again, double checking the configuration) or a SMART Mobile issue. Sharing a bug report from the app might be necessary to investigate further.



Hi Alex,

I ended up deleting the project and re-uploading it and it worked. The map also has the road names on it now.

However, it’s still a bit annoying as I now need to tell everyone to go through the same process.

The issue was only with that package. I also tried to export through device and although it ran normally, it never appeared on SMART Mobile.

Here is another error.

I was able to report an incident, it went through Connect, arrived on SMART Desktop but when I click on the incident to read the information, I get the error message from the below screenshot.

Hi Alex, please can you assist with the above error? It’s on all my CAs and I can’t get access to any data.


Hi Marine,

Apologies for the delay. Can I please ask for you to share an error log (help > View Error Log > save as .txt). I think we’ll need someone to look into what is happening here in detail as I’m not familiar with this issue.

Some additional information will help:

  1. Is this only happening with a specific package?
  2. Does this occur when recording observations under specific categories or is this all incidents?
  3. Does offline upload work or does it also result in this error?

In the meantime, as this looks like a software issue, you can attempt to backup your database and re-install SMART from a fresh install. I’ve witnessed (potentially) similar problems when a directory in the SMART installation has been corrupted somehow.



Hi Alex,

Thanks for your reply.

Attached is the error log.

The error is happening for all of my CAs, for all incidents, even previous ones that I could read before.

What do you mean by offline upload?

I have tried to export the incident as a PDF but it gives me the message “Error happened while running the report”. I see on SMART Connect on the browser that all information are there (GPS coordinates, images).

I tried to download the incident from Connect but I can only download it as a .file format which is not readable on SMART Desktop and cannot be imported. I tried change on Connect the file type but it keeps downloading it as a .file although I changed it to xml.

Noted for the software issue, I will give it a try.

Error log SMART.docx (1.4 MB)

Before re-installing SMART, if I do a backup from one of my CA, does it only save the information from that CA or does it save the information for all CAs?

I’m wondering as I did 2 backups from 2 different CAs and the folders’ sizes are different. Also when chosing the option on SMART Desktop Advanced > Restore backup, it says that all CAs in the database will be removed and replaced by the data in the backup file. But I don’t know what exactly is in this backup file.

Hi Alex,

I am able to export the incident as xml but all the images are corrupted - I cannot open them. I’m wondering if the issue comes from there.

I tried opening images from incidents from 2 different CAs and I get the same problem.

All files are jpeg though.

Hi Marine,

Interesting that it is happening on multiple CAs. This does sound like an issue with the software installation.

In answer to your above question if you go to ‘File > System Backup’ this will allow you to backup all of the CAs at once. Alternatively, you can export individual CAs by using the “conservation area export” option.

So, go ahead and do a full system back up and redownload / reinstall SMART 7.5.7 (make sure it is on a local drive, not an external hard drive), then when opening the new installation of SMART use the advanced option to “upgrade/restore a backup”.

If the issue persists after attempting this then we’ll need to dive into this in more detail.



Hi Alex,

I downloaded SMART again and when I click on upgrade/restore a backup it asks me to enter a username and passwords from one of the CAs in the database.

I tried with 3 different username and passwords that I’m 200% confident are correct but I just find it strange that it asks me this before actually selecting the backup. It’s not surprising that the software tells me the username/password is incorrect as I have not even selected the file.

I have finally managed to restore the backup.

I had to first download a CA from Connect and then I used the username and password of that CA. I could then re-download all the plugins necessary before restoring the back up.