Error exporting packages to SMART Mobile

Hi all,
I get an error notification when I try to export packages to SMART Mobile (via cable). This happened after I upgraded to 7.5.7. in order to sync with the new version of SMART Connect.
It is a very generic error message, see attached.

I tried a lot:

  • cables
  • file transfer
  • different tablet
  • USB debugging
  • re-installing SMART
  • new packages
  • Mobile settings
  • Package settings

But nothing seems to work.
Can anyone assist?
Kind regards,
Elke


s

Hi Elke,

Does the device show up in Windows Explorer?

Note that if you are using SMART Connect, you should be able to install the package over WiFi. The documentation is here: General usage | CyberTracker Wiki

Cheers,
-Justin

Hi,
It does show up in windows explored so the laptop recognizes the tablet/phone.
We only use Connect as back up.
Our packages are set on cable transfer.

Kind regards,
Elke

Can you navigate into the file system of the connected mobile device?
Does this happen on all your devices? Please share what brand they are.
Could you try on a different PC?

Cheers,
-Justin

Yes I can. I have tested multiple devices. Different laptops with the CA to export the packages. And different devices with SMART Mobile to export the packages to.

Kind regards,
Elke

I managed to install 7.5.7 via the plug-in menu of 7.5.6. Now I can export packages again.

Kind regards,
Elke

Hi,
I still get the same error notifications when I install SMART on a new laptop and try to export packages to tablets and phones.
The CA works on my own laptop so it is not the packages. The cable and tablet are also working linked to my laptop, so it is not the issue.

Do I need to change certain settings on the other laptops, in order for them to “accept” SMART?
I have had the same problem on several laptops now.

Kind regards,
Elke

On another laptop I get this error:

Looks like SMART can not get access to certain locations. I have re-installed SMART in different locations on the laptop but neither of them are working.

SMART is working but just exporting packages fails.

Kind regards,
Elke

Hi Elke,

It is hard to determine what the cause could be. Kindly share your error log so we can know more about the errors.

My assumption is there could be an antivirus that is restricting some of the executables in SMART from running. It’s a bit more evident in the second screenshot you have shared. You can confirm this by checking the antivrus’ log to see if the file “mtpcopy.exe” appears on the list of blocked applications.

Regards,

James

Hi,
Hereby the error log.
error log SMART.txt (265.3 KB)

It is there under: “Some legitimate files are not included in this log”

What does that mean?
Kind regards,
Elke

Hi Elke,

Access denied starting the copy process usually means that either the system policies (read your organization’s usage policies) or your anti-virus are not wanting to run the app.

Do you have a separate computer which you could use?

Cheers,
-Justin

Hi Justin,
I have already installed the same CAs on 8 different laptops. Some work, some don’t. Even some that are the same laptop type show different outcomes.

Is there anything else I can do in laptop settings?

Kind regards,
Elke

Sorry, I do not know. This sounds like an antivirus app issue. Is there a tech support person available?

Ideally in the longer term, we can move to using Connect, in which case you will no longer need cables. Is that an option for you?

Cheers,
-Justin

Hi Justin,
Unfortunately we dont have an IT team. Any tips for what I can look at?

I wanted to wait with Connect till we are further advanved. I also feel like the offline version should work. Especially when we dont have interner connection which happens in some.of our sites, we have to be able to switch to offline.

Kind regards,
Elke

Thanks, Elke for your patience and collaboration in resolving this issue.

For anyone else who experiences a similar issue, here are some of the things to do to avoid getting the same error:

  1. Make sure you have USB debugging turned on. You can do this by activating Developer Options in the settings menu of your Android device. The process for activating Developer Options might vary depending on the brand of the device. Refer to the device manual or Google for this.
  2. When the device is connected to a PC, make sure it is set to “File Transfer” mode and can be seen in your Windows File Explorer.
  3. If you still have challenges after doing the first two steps, download and install ADB Drivers on your PC. This driver helps your PC communicate with your Android device.