Field data error


I’m having trouble importing data from SMART mobile to SMART Desktop I get an error (image attach), it says it can’t process all the data. Why is that? What can I do to avoid losing information collected in the field?

Hello Bianca,
Can you copy the content of that window into a file to share so we can see the details? One thing you can check is whether the times associated with those points fall within the start and end time of the associated patrol. There was an issue with older versions of SMART Mobile where it could potentially collect trackpoints after the patrol was ended, but that was usually on a smaller scale. I suspect there’s an issue with the underlying data, such as incorrect/missing patrol start or end times that’s causing it to be unable to file that data, but we’d need to compare some example waypoint times to the patrol to have a better understanding of what is happening.

Sorry, I didn´t save the text. I just take the screenshot of the error, but if happen again I will send you the text.


Hi Bianca,

All of the errors should be stored in the error log within SMART. You can access it by going to ‘Help > View Error log’. You can save this as a .txt file and attach it here.

Also, do you have any idea as to what is missing when you are importing your data? Are there specific observation categories or attributes absent that you’d expect to be imported?

Please also confirm the versions of SMART and SMART Mobile. As Matt mentions, there was a similar issue in older versions so lets make sure you’re up-to-date.



Hi Alex,
error_datacouldnotbeprocessed_SMART.docx (100.8 KB)

In the option of “view error log”. I didn´t find errors for the date that I tried to process the JSON file, but I copy and paste it into Word document attached.

Hi Bianca,

I’m not sure but this problem could be related to the issue where the last waypoint of a patrol cannot be processed because it is using milliseconds for the time stamp, but the end of patrol data is only using seconds. So mots of the time the last waypoint seems to be after the end of the patrol when processing the data.
You can try to increase the end time of a patrol by just one second and then retry the processing of these waypoints


1 Like

Hello Bianca,
It looks like this list of features includes waypoints at 10-second intervals from 08:33:30 to 13:34:18 on March 8 2023. Can you confirm that there is one, and only one, existing patrol from this device in your CA where these waypoints all fall between the start and end time? I think this warning would typically mean that these waypoints are outside the time range of the patrol and therefore wouldn’t be able to be included.

Hi Matt,

In the device are 4 patrol, but the patroller said that are from diferent day. I did the process below:

  1. Save on the computer the Json files
  2. From the file uploaded to the SMART Desktop, only one file
  3. SAMRT starts processing it and gives me that message to load only the viable data for the program.
  4. I cancel the process (because we loose data if we continue the process)
    I would like to know if there is anything that the patroller do that does this or the GPS signal or something in the time program because it does not happen in all patrols but if it has become recurrent.

Thank you for your help!

Hello Bianca,
I’m not sure I understand. Are you saying that there wasn’t any patrol on March 8 and that the trackpoint data is somehow getting shifted by one or more days on the device? I’ve seen timestamps get shifted by several hours when the time zone is set incorrectly on the device, but I’m not aware of anything that would cause it to be associated with the wrong day. Is it possible that a user just forgot to end a patrol, and the extra trackpoints on March 8 are just from the patrol accidentally running longer than it was supposed to? If those trackpoints aren’t valid, you should be able to disregard the warning and process the rest of the data.

Good morning,

The device has four patrols, one was on March 8. I think the track points are valid thats why I don´t wanna disregard the warning and process the rest of the data unless there is nothing that we can do to save the data.


Hello Bianca,
I will reach out to you via email to see if we can schedule some time to take a look at this together.

Hi Bianca,
It looks like this is related to an issue that was fixed in later versions of SMART. I recommend upgrading to SMART 7 to fix this and other issues when you can.

In this case, for a patrol running overnight, the track points from midnight until the first observation entered on subsequent days are getting lost, as the start time for the patrol on subsequent days is getting set based on that first observation. To minimize the impact of this issue, you can make sure to enter an observation as soon as the patrol is starting on each subsequent day to make sure that patrol start time gets set right away.

This issue is fixed in SMART 7, so you should be able to prevent it in the future by upgrading.


Hi Matt, thank you very much for your help!

So, if I update SMART DEsktop fron 7.4.0 to the latest public version 7.5.6, and upload the patrols we recovery this patrol information? Or will not happen again into new patrols?


Hi Bianca,
It looks like the CA backup you had shared ( is from SMART 6.2, so there was some confusion around the issue you are reporting. Would you be able to share a current backup of your CA so I can have the developer take another look?

That´s weird, I will do the backup again but here is a picture when I run SMART Desktop:

Hi Bianca,
We confirmed that the earlier findings I reported still apply – this issue is fixed in the latest version of SMART, so if you upgrade from 7.4 to 7.5.6 it should take care of this issue.

Thaank you very much.

Ii will update SMART Desktop.

Best regards!!!